The service MobileLegacy is down
Incident Report for Captio
Resolved
This incident has been resolved.
Posted 10 months ago. Oct 31, 2018 - 09:31 CET
Investigating
The service is unavailable
Posted 10 months ago. Oct 31, 2018 - 09:26 CET